Σάββατο, 30 Μαΐου 2009

Προσπέλαση (από το προσπελάζω)

Ξεκινάμε ψάχνοντας ορισμούς στα λεξικά. (Το σύμβολο [<] διαβάζεται [προέρχεται από]).
Το αρχαίο ρήμα [πελάζω] σήμαινε [πλησιάζω].
Η παροιμιακή φράση [όμοιος ομοίω αεί πελάζει] σημαίνει [ο άνθρωπος πάντοτε (επιθυμεί να) συναναστρέφεται ομοίους του].
Το σύνθετο [προσπελάζω] < [προς + πελάζω] σήμαινε [πλησιάζω προς κάτι, προσεγγίζω].
Η πράξη [το πλησίασμα, η προσέγγιση] λέγεται [η προσπέλαση, της προσπέλασης] < αρχαίο [η προσπέλασις, της προσπελάσεως].
Κάποιος, που μπορούμε να τον πλησιάσουμε εύκολα, λέγεται [ο προσπελάσιμος].
Αυτός που πλησιάζει λέγεται [ο πελάτης]. Στην αρχαιότητα [πελάτης] ήταν [αυτός που πλησίαζε για να ζητήσει προστασία], σήμερα [πελάτης] είναι [αυτός που αγοράζει κάτι] ή [αυτός που έχει τακτική παρουσία, που είναι θαμώνας]. Το [σύνολο των πελατών] λέγεται [η πελατεία].

Το αρχαίο ρήμα [ελαύνω] σήμαινε [τρέχω, οδηγώ].
Η πράξη της οδήγησης μιάς μεταλλικής μάζας να περάσει βίαια μέσα από μιά οπή λέγεται [η έλαση, της έλασης] < αρχαίο [η έλασις, της ελάσεως]. Αυτό που παράγεται, ανάλογα με το σχήμα της οπής, είναι το σύρμα ή [το έλασμα].

Το σύνθετο [απελαύνω] < [από + ελαύνω] σήμαινε [διώχνω έξω από τα σύνορα].
Η πράξη, που σημαίνει εξορία < [εξ + όριο > εξορίζω], λέγεται [η απέλαση, της απέλασης] < αρχαίο [η απέλασις, της απελάσεως]. Η εξορία λεγόταν επίσης [η εξέλασις, της εξελάσεως] < [εξ + ελαύνω].
Ο φρουρός στα σύνορα του βυζαντινού κράτους, επιφορτισμένος να απωθεί τους εισερχόμενους ξένους , ονομαζόταν [ο απελάτης, του απελάτου].

Το σύνθετο [διελαύνω] < [δια + ελαύνω] σήμαινε [διέρχομαι έφιππος] ή [οδηγώ κάτι ανάμεσα από δύο εμπόδια] ή [διατρυπώ κάτι].
Η πράξη λέγεται (για μεταλλική κατεργασία) [η διέλαση, της διέλασης] < αρχαίο [η διέλασις, της διελάσεως].

Το σύνθετο [επελαύνω] < [επί + ελαύνω] σήμαινε [εφορμώ (συνήθως με ιππικό), επιτίθεμαι εναντίον κάποιου].
Η πράξη λέγεται [η επέλαση, της επέλασης] < αρχαίο [η επέλασις, της επελάσεως].

Το σύνθετο [παρελαύνω] < [παρά + ελαύνω] σήμαινε [περνώ μαζί με άλλους, όλοι συντεταγμένοι σε φάλαγγες].
Η πράξη λέγεται [η παρέλαση, της παρέλασης] < αρχαίο [η παρέλασις, της παρελάσεως].

Τώρα που τα γνωρίζουμε όλα αυτά, ας διαβάσουμε το Θέμα 1.Α.3 από το σημερινό διαγώνισμα για ΑΕΠΠ : [Όταν γίνεται σειριακή αναζήτηση κάποιου στοιχείου σε έναν μη ταξινομημένο πίνακα και το στοιχείο δεν υπάρχει στον πίνακα, τότε υποχρεωτικά προσπελαύνονται όλα τα στοιχεία του πίνακα].

Παραβλέπω ότι θα έπρεπε να λέμε [σειραϊκή] και όχι [σειριακή], αφού [Συριακή] ήδη σημαίνει [αυτήν από την Συρία]!
Αυτό που είναι οφθαλμοφανές, αλλά κανείς δεν νοιάστηκε να διορθώσει στο κείμενο του διαγωνίσματος, είναι ότι θα έπρεπε η ανύπαρκτη και ακατανόητη λέξη [προσπελαύνονται] να φύγει και η παράγραφος να αντικατασταθεί από την…

[Όταν γίνεται σειριακή αναζήτηση κάποιου στοιχείου σε έναν μη ταξινομημένο πίνακα και το στοιχείο δεν υπάρχει στον πίνακα, τότε η διαδικασία αναζήτησης πρέπει να προσπελάσει υποχρεωτικά όλα τα στοιχεία του πίνακα].

Το ότι ασχολούμαστε εντατικά με την πληροφορική δεν δικαιολογεί την κακοποίηση της γλώσσας μας.

Παρασκευή, 22 Μαΐου 2009

Άλλο ένα διαγώνισμα ΑΕΠΠ με απαντήσεις

Σε μια προηγούμενη ανάρτηση είχα δώσει συνδέσμους προς μερικά κείμενά μου σχετικά με πληροφορική. Σήμερα άλλαξα το κείμενο με τα απαντημένα διαγωνίσματα ΑΕΠΠ, το οποίο περιέχει πλέον τέσσερα διαγωνίσματα (τρία πραγματικά - ένα φανταστικό).

Όσοι ενδιαφέρονται, θα μπορούσαν να διαθέσουν λίγο χρόνο για να επισκοπήσουν το βιβλίο για δομημένο προγραμματισμό και τις απαντήσεις των διαγωνισμάτων και να διαβάσουν τα διάσπαρτα σχόλια.

Θέλω να πιστεύω ότι, όσο καλά και να γνωρίζουν το αντικείμενο, σίγουρα θα βρουν κάτι χρήσιμο εκεί.

Τετάρτη, 13 Μαΐου 2009

Δωρεάν φορητοί Η/Υ στα πρωτάκια

Διάβασα εδώ ότι την ερχόμενη σχολική χρονιά θα δοθούν 120000 υπολογιστές στην Α' Γυμνασίου.

Ενδιαφέρουσα υπόσχεση! Μένει να δούμε την πράξη...


...αργότερα (φθινόπωρο 2009)...
δόθηκαν κουπόνια για αγορά μικρών υπολογιστών (netbooks) με λειτουργικά που χειάζονται αναβάθμιση, με εφαρμογές-office που χρειάζονται αναβάθμιση εντός τριμήνου, με κινδύνους επίθεσης από ιούς για τους οποίους χρειάζονται αντιιικά (δόκιμη λέξη;) προγράμματα, ενίοτε χωρίς σχολικά βοηθήματα.
Οι τιμές στην αγορά έφθασαν εύκολα στο ύψος που κάλυπτε το κουπόνι.

Καμμιά σκέψη για τον φορητό OLPC XO, που σχεδιάστηκε ειδικά για εκπαίδευση παιδιών, που έχει λογισμικό ανοικτό και μεταφρασμένο στην γλώσσα μας, που είναι φθηνότερος, άθραυστος, που ενημερώνεται από το διαδίκτυο για αναβαθμίσεις λογισμικού και για νέα βιβλία και μαθήματα, κλπ κλπ, τι να τα λέμε τώρα...


...πολύ αργότερα (καλοκαίρι 2010)...
μάθαμε ότι θα σταλούν δέκα φορητοί σε κάθε σχολείο και ένας φοριαμός φύλαξης.
Οι υπολογιστές θα μένουν στο σχολείο και θα χρησιμοποιούνται σε μαθήματα κατά περίπτωση.
Με τριάντα μαθητές στην τάξη ή με δέκα υπολογιστές ανά σχολείο, κάτι είναι πολύ στραβό στον προγραμματισμό της σχολικής εκπαίδευσης.

Αν οι υπολογιστές ανήκαν στα παιδιά, θα μπορούσαν να μαθαίνουν όλες τις ώρες που θα είχαν διαθέσιμες!

Αν ένα μηχάνημα το χειρίζονται περισσότεροι χρήστες, χαλάει πολύ πιο γρήγορα. Ρωτήστε τις εταιρείες συντήρησης αν δεν με πιστεύετε!

Τρίτη, 5 Μαΐου 2009

Πράξεις σε μέρος ενός Πίνακα

Όταν χρησιμοποιούμε έναν Πίνακα, μπορεί να υποχρεωθούμε να κάνουμε πράξεις με ένα υποσύνολο των στοιχείων του.

Γενικά, ο Πίνακας έχει ένα όνομα, έστω Πιν.
Ορίζουμε έναν δείκτη γρα, που θα μας δείχνει σε ποιά γραμμή του πίνακα είμαστε, και μια μέγιστη τιμή αυτού του δείκτη : γραμαξ.
Ορίζουμε έναν δείκτη στη, που θα μας δείχνει σε ποιά στήλη του πίνακα είμαστε, και μια μέγιστη τιμή αυτού του δείκτη : στημαξ.
Ο πίνακας έχει πλήθος στοιχείων (γραμαξ x στημαξ), και αν είναι τετραγωνικός θα έχουμε γραμαξ=στημαξ.

Το πρόβλημα που δίνουμε σήμερα είναι το εξής : Σε έναν τετραγωνικό πίνακα 20x20 βάζουμε κατά γραμμές τους αριθμούς 1, 2, 3, ..., 400. Ο πίνακας έχει μια διαγώνιο από Πιν[1,1] μέχρι Πιν[20,20]. Θέλουμε να φτιάξουμε ένα πρόγραμμα σε ΓΛΩΣΣΑ που θα τυπώνει τον μέσο αριθμητικό των στοιχείων του πίνακα που βρίσκονται κάτω από την διαγώνιο αυτή, τον μέσο αριθμητικό των στοιχείων που ορίζουν την διαγώνιο, και τον μέσο αριθμητικό των στοιχείων του πίνακα που είναι πάνω από την διαγώνιο.

Για να βάλουμε τις αρχικές τιμές, χρησιμοποιούμε τιμές γραμμο-δείκτη γρα από 1 μέχρι γραμαξ, και τιμές στηλο-δείκτη στη από 1 μέχρι στημαξ. Όταν όμως προχωρήσουμε σε πράξεις σε μέρη του πίνακα, προσέχουμε πολύ στον καθορισμό των ορίων μεταβολής του καθενός δείκτη. Παρακάτω γράφουμε το πρόγραμμα και την απάντηση.
Φτιάξτε το δικό σας πρόγραμμα ως άσκηση, βρείτε τους τρεις μέσους όρους, και μετά συγκρίνετε τα προγράμματα και τις απαντήσεις.

ΠΡΟΓΡΑΜΜΑ μο3
! Βάζουμε ακέραιους αριθμούς (1, 2, 3, ...) σε έναν τετραγωνικό πίνακα κατά γραμμές
! και βρίσκουμε τους μέσους όρους στο αριστερό κάτω τριγωνικό μέρος, στην διαγώνιο,
! και στο δεξιό πάνω τριγωνικό μέρος του πίνακα

ΜΕΤΑΒΛΗΤΕΣ
__ΑΚΕΡΑΙΕΣ: Πιν[20, 20], γρα, γραμαξ, στη, στημαξ, πλήθος, άθροισμα
__ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟαριστερά, ΜΟδιαγώνια, ΜΟδεξιά
ΑΡΧΗ
γραμαξ <- 20
στημαξ <- 20

! τοποθέτηση αρχικών τιμών στον Πίνακα κατά γραμμές

πλήθος <- 0
ΓΙΑ γρα ΑΠΟ 1 ΜΕΧΡΙ γραμαξ
__ΓΙΑ στη ΑΠΟ 1 ΜΕΧΡΙ στημαξ
____πλήθος <- πλήθος + 1
____Πιν[γρα, στη] <- πλήθος
__ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! εύρεση του μέσου όρου των αριστερών

πλήθος <- 0
άθροισμα <- 0
ΓΙΑ γρα ΑΠΟ 2 ΜΕΧΡΙ γραμαξ
__ΓΙΑ στη ΑΠΟ 1 ΜΕΧΡΙ γρα - 1
____πλήθος <- πλήθος + 1
____άθροισμα <- άθροισμα + Πιν[γρα, στη]
__ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟαριστερά <- άθροισμα/πλήθος

! εύρεση του μέσου όρου των διαγωνίων

πλήθος <- 0
άθροισμα <- 0
ΓΙΑ γρα ΑΠΟ 1 ΜΕΧΡΙ γραμαξ
__πλήθος <- πλήθος + 1
__άθροισμα <- άθροισμα + Πιν[γρα, γρα]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟδιαγώνια <- άθροισμα/πλήθος

! εύρεση του μέσου όρου των δεξιών

πλήθος <- 0
άθροισμα <- 0
ΓΙΑ γρα ΑΠΟ 1 ΜΕΧΡΙ γραμαξ - 1
__ΓΙΑ στη ΑΠΟ γρα + 1 ΜΕΧΡΙ στημαξ
____πλήθος <- πλήθος + 1
____άθροισμα <- άθροισμα + Πιν[γρα, στη]
__ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟδεξιά <- άθροισμα/πλήθος

! εκτύπωση των τριών μέσων όρων

ΓΡΑΨΕ 'Μέσοι όροι : Αριστερών=', ΜΟαριστερά, ', Διαγωνίων=', ΜΟδιαγώνια, ' και Δεξιών=', ΜΟδεξιά
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Όταν εκτελεστεί το πρόγραμμα αυτό, δίνει απάντηση :

Μέσοι όροι : Αριστερών=267.00, Διαγωνίων=200.50 και Δεξιών=134.00